roxow

Membro
  • Total de itens

    23
  • Registro em

  • Última visita

Reputação

3 Iniciante

Sobre roxow

Últimos Visitantes

88 visualizações
  1. urgente

    Creio que seja na tabela acc_reg_num_db, as linhas CASHPOINT são os rops.
  2. Creio eu que falta um ")" na linha if (countitem(6396)<1) && countitem(5401)<1){goto L_norew; end;}
  3. Creio eu que isso ocorre por não haver nenhuma chave primária nessa tabela. Eu uso o programa MySQL-Front, acho mais fácil editar as coisas através dele.
  4. Galera, estou usando as confs de pre-renewal. O que acontece é que o ataque mágico está sendo considerado ataque a distância, ou seja se o usuário utilizar besouro de chifre por exemplo, vai diminuir o dano de ataque mágico. como posso alterar isso? Desde já agradeço
  5. Tente RC_Player, aqui eu consigo ignorar a defesa assim.
  6. Obrigado galera, eu pedi para que dessem permissão e até mudassem a compatibilidade, mas sabem como é né? Vou pegar uma máquina com win 10 e vou realizar os testes, se conseguir atualizo o tópico com os procedimentos.
  7. Saudações galera! Muitos jogadores não conseguem jogar meu servidor com Windows 10. Ao clicar em start pelo autopatcher o jogo mostra o gameguard e não inicia. Utilizo o hexed 2012-07-16 e o Ragnaguard (Seria ele) Agradeço desde já!
  8. Vou mostrar como eu faria. weapontable.lua (pasta luafiles514/luafiles/datainfo) WEAPONTYPE_Adagas_Supremas = 101 [Weapon_IDs.WEAPONTYPE_Adagas_Supremas] = "_Adagas_Supremas" [Weapon_IDs.WEAPONTYPE_Adagas_Supremas] = Weapon_IDs.WEAPONTYPE_SHORTSWORD, Pasta Sprite/Classe mercenário ¾î¼¼½Å ¾î¼¼½Å_¿©_Adagas_Supremas.act ¾î¼¼½Å_¿©_Adagas_Supremas.spt ¾î¼¼½Å_³²_Adagas_Supremas.act ¾î¼¼½Å_³²_Adagas_Supremas.spt E analisando agora, acho que não está mostrando na classe Algoz, pq o sprite está na pasta pada cavaleiro. ItemInfo.lub [20001] = { unidentifiedDisplayName = "Espada", unidentifiedResourceName = "¼Òµå", unidentifiedDescriptionName = { "Item não identificado, pode ser identificado com [Lupa].", "Peso : ^77777750^000000", }, identifiedDisplayName = "Adagas Supremas", identifiedResourceName = "Adagas_Supremas", identifiedDescriptionName = { "Descrição do item.^000000", "Classe: ^777777Adaga^000000", "Força de Ataque: ^77777770^000000", "Peso: ^77777750^000000", "Nível da arma: ^7777772^000000", "Nível necessário: ^77777714^000000", "Classes que utilizam: ^777777Aprendiz/ Espadachim/ Mercador/ Gatuno e as respectivas evoluções^000000", }, slotCount = 4, ClassNum = 101 (mesma classe do weapontable.lub) }, Itemdb: 20001,Adagas_Supremas,Adagas_Supremas,4,100,,500,25,,,1,4,4294967295,,2,2,1,2,,1,2,,,,,,,,,,,,bonus bStr,100;
  9. Então na pasta dos sprites do char devem estar assim ÆäÄÚÆäÄÚ_±â»ç_¿©_Adagas_Supremas.spr" e "ÆäÄÚÆäÄÚ_±â»ç_¿©_Adagas_Supremas.act"
  10. Creio que o problema seja no sprite da arma na pasta do mercenário, o nome do sprite está correto? Está 1117? Por exemplo, no ItemInfo.lub o "identifiedResourceName = "1117" deveria estar assim, pois deve ser o mesmo nome do sprite na pasta. O Classnum eu acho que deve ser o mesmo número do weapontable.lub
  11. Talvez seja o random, ele tem que estar 1(ativado). Se eu não me engano, se estiver 0 no random ele vai dar o item na certa. Comigo está funcionando, vou mostrar como fiz. Como pode observar, todos estão com random 1, no count a qtd de itens que eu quero que dê. Ao abrir um "presente de aniversário" o player ganhará um item da lista, por exemplo 5 Galhos Sangrentos. presente_aniversario2: { Old_Blue_Box: { Random: 1 Rate: 81 } Bloody_Dead_Branch: { Random: 1 Count: 5 Rate: 60 } Bubble_Gum_Box: { Random: 1 Count: 1 Rate: 60 } Gift_Box: { Random: 1 Rate: 70 } Red_Bag: { Random: 1 Count: 3 Rate: 70 } Cool_Summer_Outfit: { Random: 1 Count: 3 Rate: 70 } Gold_Coin: { Random: 1 Count: 100 Rate: 80 } Copper_Coin: { Random: 1 Count: 100 Rate: 80 } Silver_Coin: { Random: 1 Count: 100 Rate: 80 } Mithril_Coin: { Random: 1 Count: 100 Rate: 80 } White_Gold_Coin: { Random: 1 Count: 100 Rate: 80 } }
  12. É o seguinte. Count é o número de itens que vai vir. Rate é a chance do item vir. Rate: 1 se não me engano é 0,01% Como você tem apenas dois itens nessa lista, creio que a chance de vir um ou outro é maior, pois serão só duas opções.
  13. Então, parece ser um erro no código do npc, como o erro diz: Encontrou "@Email$" mas provavelmente deveria ser "@email$"; Abra o npc, procure essa linha e altere, talvez tenha mais erros... Ai vc vai alterando conforme os erros que vão aparecendo ai no map-server.
  14. kakunxd, olha sobre o comando eu não sei responder. Sobre essa instabilidade, o meu também ocorria algo semelhante com o login-server quando os jogadores erravam a senha um número x de vezes. Para resolver isso eu entrei no login-server.conf E alterei a linha: // Ipban features (SQL only) ipban.enable: yes //ipban.sql.db_hostname: 127.0.0.1 //ipban.sql.db_port: 3306 //ipban.sql.db_username: ragnarok //ipban.sql.db_password: ragnarok //ipban.sql.db_database: ragnarok //ipban.sql.codepage: //ipban.sql.ipban_table: ipbanlist // Sistema de ban por IP para consecutivos erros de senha. ipban.dynamic_pass_failure_ban: yes ipban.dynamic_pass_failure_ban_interval: 5 ipban.dynamic_pass_failure_ban_limit: 7 ipban.dynamic_pass_failure_ban_duration: 5 Para: // Ipban features (SQL only) ipban.enable: no //ipban.sql.db_hostname: 127.0.0.1 //ipban.sql.db_port: 3306 //ipban.sql.db_username: ragnarok //ipban.sql.db_password: ragnarok //ipban.sql.db_database: ragnarok //ipban.sql.codepage: //ipban.sql.ipban_table: ipbanlist // Sistema de ban por IP para consecutivos erros de senha. ipban.dynamic_pass_failure_ban: yes ipban.dynamic_pass_failure_ban_interval: 5 ipban.dynamic_pass_failure_ban_limit: 7 ipban.dynamic_pass_failure_ban_duration: 5
  15. Olá Dreyar, será que o problema não seria no clientinfo? tente deixar as confs: <version>22</version> <langtype>12</langtype>