Entre para seguir isso  
Seguidores 0
liutravos

[Ajuda] Conectando no servidor

10 posts neste tópico

O negócio é o seguinte, eu tenho uma rede em casa, roteada da Net Virtua.

 

Em um dos meus pcs tem um linux ubuntu atualizado rodando uma versão renovação do brAthena configurado na mmo pra 20120410, com packetdb 30, com todas as tabelas do SQL dentro da mesma tabela e alterado no inter_athena direitinho todas na mesma tabela.

 

O problema é que, qualquer tentativa de conexão, o servidor acha o login perfeito e diretinho e automaticamente fecha a conexão. Pode ser o hexed ou é algo do servidor?

 

 

Eu estou usando um dif próprio com a pasta do MegaSantos tudo aparentemente direitinho, já tentei coisas demais e nada deu resultado =/

 

detalhe: esse lance de todas as tabelas é que me parece que a db tinha que ficar diferente da log que tinha que ser diferente da ragnarok, algo assim, não sei se isso influenciaria maaaaaaas, não custa falar, toda ajuda é bem vinda

0

Compartilhar este post


Link para o post
Compartilhar em outros sites

vc tem q criar 2 bancos de dados,um com o nome "ragnarok" e o outro "log"

 

 

ou se vc preferir usar apenas um banco de dados.

vá em conf e abra inter_athena

e procure isso:

 

// Banco de dados de logs.

log_db_ip: 127.0.0.1

log_db_port: 3306

log_db_id: root

log_db_pw: vertrigo

log_db_db: log

log_codepage:

 

mude o nome do banco de dados de log para ragnarok.

0

Compartilhar este post


Link para o post
Compartilhar em outros sites

Eu mudei :) o dele e o do db

 

No caso pelo inter diz que Log e DB tem que ter um database excluso, eu junteis os 2 e mudei no inter, tanto que quando eu inicio os serviços ele fala que tá tudo okay, meu problema é na hora de logar, ele valida a conta e encerra a conexão automaticamente

0

Compartilhar este post


Link para o post
Compartilhar em outros sites

// Banco de dados de logs.

log_db_ip: 127.0.0.1 <--- Tenta por aqui localhost em todos

log_db_port: 3306

log_db_id: root

log_db_pw: vertrigo

log_db_db: log

log_codepage:

Editado por Toddy
0

Compartilhar este post


Link para o post
Compartilhar em outros sites

Hmmm não tinha pensado nisso, vou tentar no almoço. Alguma outra idéia? :3

 

E no caso mudo o IP do char_athena / Login_athena / map_athena?

0

Compartilhar este post


Link para o post
Compartilhar em outros sites

O IP da máquina:

 

Dentro da rede? (192.182.1.102)

Localhost?

127.0.0.1?

 

Na duvida tentarei todos e_e

 

Mas é estranho por que mostra no Map-server que a minha conta tentou logar e inclusive registra no banco a tentativa de login....

0

Compartilhar este post


Link para o post
Compartilhar em outros sites

verifique tb se seu client esta altorisado ao servidor no src/common/mmo.h olhe se a data é a mesma so seu hexed

va tb na db e olhe se o seu packet_db.txt esta com a devida Versão do seu haxed

0

Compartilhar este post


Link para o post
Compartilhar em outros sites

Bom, eu resolvi com base em uma dica do @toddy

 

Eu usei realmente o IP do modem, não o da rede, nem local, nem 127.0.0.1 hahaha, usei o site meuip, peguei o IP do modem e troquei nos arquivos char_athena, login_athena, map_athena e troquei 127.0.0.1 por localhost no arquivo inter_athena.

 

No roteador: abri a porta do mysql embora eu ache que isso não foi a solução e fiz um redirecionamento dessa porta para o PC com linux

 

Enfim, resolvido, obrigado a todos :)

0

Compartilhar este post


Link para o post
Compartilhar em outros sites
Visitante
Este tópico está impedido de receber novos posts.
Entre para seguir isso  
Seguidores 0