Entre para seguir isso  
Seguidores 0
L o n e l y

SQL
[Resolvido] Erro ao importar Renovacao

9 posts neste tópico

Iaew pessoal.

Bom, sou novato nessa Área de Ragnarok.

e recentemente se deparei com um erro na Importação da "renovacao.sql".

 

 

 

2nkrux2.jpg

 

 

 

E os vários erros aparecem no map-server

alguns são referentes a npc...

outros ao "renovacao.sql"

 

 

 

nq1nw1.jpg

 

 

 

Bom no Game, entra tudo certo, só que:

Não tem monstro

Não tem ekips

Não tem como colocar pontos nas Skill

 

Alguém poderia ajudar ? :S

Editado por L o n e l y
0

Compartilhar este post


Link para o post
Compartilhar em outros sites

Se não me engano isso acontece pq o arquivo SQL é muito grande, então alguns desses programas de PHPmyadmin tipo o Vertrigo (por exemplo) não abrem o arquivo todo, então para importar a tabela vc deverá abri-lá como arquivo de texto, da um "ctrl a" e em seguida um "ctrl v" na aba "sql" do PHPmyadmin, isso fará com que todo o arquivo SQL seja lido e consequentemente as tabelas serão criadas corretamente, pois se você olhar bem os erros são referente a falta dessas tabelas.

Editado por Clare
0

Compartilhar este post


Link para o post
Compartilhar em outros sites

10qjg2o.jpg

 

Se não me engano isso acontece pq o arquivo SQL é muito grande, então alguns desses programas de PHPmyadmin tipo o Vertrigo (por exemplo) não abrem o arquivo todo, então para importar a tabela vc deverá abri-lá como arquivo de texto, da um "ctrl a" e em seguida um "ctrl v" na aba "sql" do PHPmyadmin, isso fará com que todo o arquivo SQL seja lido e consequentemente as tabelas serão criadas corretamente, pois se você olhar bem os erros são referente a falta dessas tabelas.

Bom, fiz oque você disse, mas não deu muito certo :S

continuou o mesmo erro :S

 

hurf68.jpg

0

Compartilhar este post


Link para o post
Compartilhar em outros sites

Então realmente se trata de um erro na tabela, provavelmente algo digitado errado na parte referente ao mob_boss_db

creio que nessa linha

REPLACE INTO `mob_boss_db` VALUES(0,'Bafomé',1039);

você pode abrir o arquivo sql como arquivo de texto novamente, procurar por algo semelhante a isso

Estrutura da tabela `mob_boss_db

em seguida veja as linhas

CREATE TABLE IF NOT EXISTS `mob_boss_db` (
  `MobID` smallint unsigned NOT NULL,
  `DummyName` varchar(30) NOT NULL,
  `Rate` int unsigned NOT NULL
) ENGINE=MyISAM DEFAULT CHARSET=latin1;
 

REPLACE INTO `mob_boss_db` VALUES(0,'Bafomé',1039);
REPLACE INTO `mob_boss_db` VALUES(1038,'Osíris',500000);
REPLACE INTO `mob_boss_db` VALUES(1039,'Bafomé',500000);
REPLACE INTO `mob_boss_db` VALUES(1046,'Doppelganger',500000);
REPLACE INTO `mob_boss_db` VALUES(1059,'Abelha-Rainha',500000);

compare as linhas com essas e veja se está faltando algo, tente corrigir se achar algo diferente, caso não dê certo ou não consiga fazer então será melhor esperar alguém resolver o problema na DB do emulador.

Caso consiga corrigir achar o erro, salve as alterações e importe novamente o arquivo SQL ao seu programa de PHPmyadmin

Editado por Clare
0

Compartilhar este post


Link para o post
Compartilhar em outros sites

O problema é que está na primeira e na terceira linha, não pode haver um monstro com nome idêntico.

Está assim:

REPLACE INTO `mob_boss_db` VALUES(0,'Bafomé',1039);
REPLACE INTO `mob_boss_db` VALUES(1038,'Osíris',500000);
REPLACE INTO `mob_boss_db` VALUES(1039,'Bafomé',500000);

Deveria estar assim:

REPLACE INTO `mob_boss_db` VALUES(0,'Baphomet',1039);
REPLACE INTO `mob_boss_db` VALUES(1038,'Osíris',500000);
REPLACE INTO `mob_boss_db` VALUES(1039,'Bafomé',500000);

Faz o seguinte, deleta seu banco de dados, e refaz ele importando brAthena.sql, Logs.sql e o Renovação.sql que vou deixar em link: http://www.mediafire.com/download/ir546u1ncr1g6i4/renovacao.sql

0

Compartilhar este post


Link para o post
Compartilhar em outros sites

Titus não tenho certeza se é isso mesmo em, no meu mob_boss_db os mobs possuem o mesmo nome e foram importados normalmente :x

10981696_532954580179605_221046109757992

Maaaaaas, não sei né pq meu emulador não é exatamente esse ultimo que está disponível


Não posto minha renovação.sql pois fiz diversas modificações no arquivo

 

Editado por Clare
0

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Clare meu anjo na realidade não entendi bem o porque de ter dado o erro nele, mas já vi outras pessoas terem o mesmo problema, então talvez seja a versão do phpMyAdmin que ele utiliza, enfim... o renovação que mandei para ele é o mesmo do SVN, só alterei o nome do bafomé na primeira linha =P

Vou manter o tópico aberto por mais um tempo, talvez alguém tenha alguma informação útil para nos dar e explicar o real motivo =)

0

Compartilhar este post


Link para o post
Compartilhar em outros sites
Visitante
Este tópico está impedido de receber novos posts.
Entre para seguir isso  
Seguidores 0