Entre para seguir isso  
Seguidores 0
Johnny.

DATABASE
Banco de dados ou item_db.conf?

5 posts neste tópico

Olá, estou parado há um tempo no mundo dos servidores, e estou voltando agora.

Estava configurando um servidor com o brAthena, e quando fui alterar alguns itens lá no banco de dados (phpMyAdmin), percebi que não havia mudado nada in-game.

Descobri então que o servidor está lendo o arquivo "db/pre-renewal/item_db.conf" ao invés de pegar as informações do banco de dados.

Por que ele está lendo desse arquivo? Como faço pra ele voltar a ler do banco de dados ao invés do arquivo?

Obrigado desde já.

0

Compartilhar este post


Link para o post
Compartilhar em outros sites

Agora é tudo em sql :D bem mais prático e mais rápido...

 

Agora teu problema, nunca vi isso mano você compilou normal, fez alguma alteração errada ? Se pa baixa emulador novamente

Editado por daelGyn
0

Compartilhar este post


Link para o post
Compartilhar em outros sites

Então, quando eu fazia servidor já era tudo em sql (pelo banco de dados), o meu problema aqui é que por algum motivo o servidor está usando o arquivo ao invés de usar o banco de dados.

Como eu estava há um tempo afastado, segui esse tutorial pra me relembrar de tudo: http://brathena.org/wiki/index.php?title=Guia_para_Iniciantes

Fiz tudo exatamente como mandou lá. E lá manda fazer/usar banco de dados e tal.

Editado por Johnny.
0

Compartilhar este post


Link para o post
Compartilhar em outros sites

src/config/core.h

linha 79

/// Retire o comentário de definição para que a item_db seja carregada em SQL.
//#define USE_SQL_ITEM_DB

/// Retire o comentário de definição para que a mob_db seja carregada em SQL.
//#define USE_SQL_MOB_DB

Só tirar o comment

0

Compartilhar este post


Link para o post
Compartilhar em outros sites

src/config/core.h

linha 79

/// Retire o comentário de definição para que a item_db seja carregada em SQL.
//#define USE_SQL_ITEM_DB

/// Retire o comentário de definição para que a mob_db seja carregada em SQL.
//#define USE_SQL_MOB_DB

Só tirar o comment

 

Depois que eu removi os comentários, quando abri o servidor deu vários erros, e todos os itens viraram "Maçãs", na aba 'etc'.

E também, quando dou @mobinfo em algum monstro, fala que ele não dropa nada.

 

O servidor está configurado direitinho, e tá funcionando, porque tá ficando online e consigo me logar.

 

Parece que ele não está lendo as tabelas item_db e mob_db :/

Editado por Johnny.
0

Compartilhar este post


Link para o post
Compartilhar em outros sites
Visitante
Este tópico está impedido de receber novos posts.
Entre para seguir isso  
Seguidores 0