dazedsex

guia e orientação
Restrições de Skill

12 posts neste tópico

Alguém poderia me ajudar?

estou com um problema com as skill, no caso eu estou criando um servidor 999/500 , e os players teriam as skill sem restrições, no caso ( ASURA sem precisar usar ZEN e FURIA,)

se alguém puder me ajudar com isso, agradeceria muito. 

obs. sou novo em criação. me desculpe se estiver algo errado.!

 

0

Compartilhar este post


Link para o post
Compartilhar em outros sites

eu te mandei umas dicas de como remover os requisitos das skills, mas acabei esquecendo que você pode tambem modificar as configurações aqui:

https://github.com/brAthena/brAthena/blob/master/conf/battle/player.conf

nessas linhas

// Configuração que define se um jogador normal pode ultrapassar a árvore de habilidades? (Nota 1)
	player_skillfree: no
	// Configuração que configura a utilização dos pontos de primeira classe. Quando se utiliza "yes", obrigará que os pontos de habilidades da primeira classe sejam utilizados, como aprendizes que precisam das habilidades básicas. (Nota 1)
	player_skillup_limit: yes

 

Porem ainda é necessário alterar as lua files, pois os clients mais recentes upam os requisitos instantaneamente se clicar em uma habilidade não aprendida, como expliquei por MP.

Editado por fxfreitas
0

Compartilhar este post


Link para o post
Compartilhar em outros sites
17 horas atrás, fxfreitas disse:

eu te mandei umas dicas de como remover os requisitos das skills, mas acabei esquecendo que você pode tambem modificar as configurações aqui:

https://github.com/brAthena/brAthena/blob/master/conf/battle/player.conf

nessas linhas

// Configuração que define se um jogador normal pode ultrapassar a árvore de habilidades? (Nota 1)
	player_skillfree: no
	// Configuração que configura a utilização dos pontos de primeira classe. Quando se utiliza "yes", obrigará que os pontos de habilidades da primeira classe sejam utilizados, como aprendizes que precisam das habilidades básicas. (Nota 1)
	player_skillup_limit: yes

 

Porem ainda é necessário alterar as lua files, pois os clients mais recentes upam os requisitos instantaneamente se clicar em uma habilidade não aprendida, como expliquei por MP.

eu modifiquei no emulador., mais esse skilltreeview.lub, ta bugado e o .lua n tem esse needskill

skilltreeview.lua

0

Compartilhar este post


Link para o post
Compartilhar em outros sites

bom, fica na pasta skillinfo dentro da pasta lua files, da uma boa olhada. Não é todas as skills que tem esse requisito.

@edit ops, corrigido, tá até no client-side do git do brA:

https://github.com/brAthena/Client-Side/blob/master/Lua Files/2014/luafiles514/lua files/skillinfo/skilltreeview.lub

Editado por fxfreitas
0

Compartilhar este post


Link para o post
Compartilhar em outros sites
1 hora atrás, fxfreitas disse:

bom, fica na pasta skillinfo dentro da pasta lua files, da uma boa olhada. Não é todas as skills que tem esse requisito.

@edit ops, corrigido, tá até no client-side do git do brA:

https://github.com/brAthena/Client-Side/blob/master/Lua Files/2014/luafiles514/lua files/skillinfo/skilltreeview.lub

fiz aq mano, mais n funcionou e deu erro. me desculpe se fiz algo de errado. olhe o arquivo, 

skilltreeview.lub

0

Compartilhar este post


Link para o post
Compartilhar em outros sites

Mano é muito estranho, eu estava com o emulador Cronus. eu apenas coloquei YES em uma questão. e funcionou normalmente, tava usando skill sem restrições normal. pq no emualdor do Brathena não quer dar ? :s
 

0

Compartilhar este post


Link para o post
Compartilhar em outros sites
2 minutos atrás, fxfreitas disse:

por um acaso consegue dizer qual erro aparece?

como faço pra Postar Imagen aqui ?

0

Compartilhar este post


Link para o post
Compartilhar em outros sites

Consegui achar o Erro, estava em Groups.conf , permissions: {
        can_trade: true
        can_trade_bound: false
        can_party: true
        all_skill: true
        all_equipment: true
        skill_unconditional: true
        use_check: true
        use_changemaptype: true
        all_commands: true
        hchsys_admin: true

 

 

no caso estava como 

 can_trade: true
        can_trade_bound: false
        can_party: true
        all_skill: false
        all_equipment: true
        skill_unconditional: false
        use_check: true
        use_changemaptype: true
        all_commands: true
        hchsys_admin: true

Obg ai  fxFreitas , pelo tempo gasto e desculpe qualquer coisa. :s

Podem feixar o Topico.

Resolvido

fxfreitas

 

f   

Editado por dazedsex
0

Compartilhar este post


Link para o post
Compartilhar em outros sites

ah é, esse detalhe, tanta coisa muda de um emulador pro outro que acabo esquecendo.

0

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!


Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.


Entrar Agora