Entre para seguir isso  
Seguidores 0
luizpkncc

Problema com client

2 posts neste tópico

Olá, estou precisando de uma ajuda sera que alguém pode me ajudar? ^^

Esse erro e fácil para vocês que estão bastante avançado mas para mim...

Bom o problema e o seguinte o emulador roda tudo certinho sem apresentar erro algum, configurei o patch da maneira que o tutorial me ensino, abro o hexad normal porem na hora de logar, entrar na conta, aparece desconectado do servidor. aparece o seguinte "erro chr parse_char: recebido pacote desconhecido 0x64"

Observação: estou querendo só para teste.

Editado por luizpkncc
0

Compartilhar este post


Link para o post
Compartilhar em outros sites

Você configurou a versão do seu hexed no emulador?

 

Abra o seguinte arquivo do seu emulador:
src/common/mmo.h

 

Pesquise pela linha:

#define PACKETVER

(Está bem no inicio do arquivo)

Essa linha define qual a versão do hexed é compátivel com seu servidor.

No meu caso:

#define PACKETVER 20140305

Significa que eu uso o hexed 2014-03-05. Qualquer outro hexed que tentar logar no meu servidor vai dar erro na hora que selecionar o personagem.

Importante:
Após a modificação, pare seu emulador, recompile e inicie novamente.

Editado por ragjr
0

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!


Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.


Entrar Agora
Entre para seguir isso  
Seguidores 0